Stripe Payment Not Working

I am putting together a nodejs serverless package that can be easily deployed on AWS, then I will build components that can talk to the AWS server which will then communicate to stripe. This will allow each maker to PCI compliant and each maker will be able to choose their server location for the payment processing. The code and useage will be small enough that the AWS free-tier will work.


Do you have a timeline?

I expect over the weekend to have v1 as Alex is our #1 patreon so solving his problem is priority to all others (on the free marketplace stuff, we still have paying contracts that superceed). Perks of altruism without expected reciprocation.

Oh okay, i see

Well I guess I won’t be solving this too soon…

@alexstockman, send me an email and we can have a chat about the future, if you want.

From Adalo support:

“We are in the process of building a whole new set of stripe components so the team isn’t working on bugs within the current Stripe Component at this time. I don’t know the exact ETA but it is actively being worked on and tested so the release of the new component should be pretty soon.”

I don’t know if you watch South Park, but there is a 3 part Game of Thrones episode. From what I keep seeing, this is like when they meet George RR Martin…

It’s coming soon! It’s on it’s way!

It’s South Park, so NSFW…

1 Like

LOL. Just look at how long the items in the roadmap have been open… Meanwhile you’re releasing a feature a day it seems like.

Pretty big slap in the face that adalo quietly rolled out a new stripe component without mentioning it to any of the users who’ve projects have gone to complete ruin because of it.

Support first tried telling me it was something I did. Then finally they admit it wasn’t working and are developing it, as they insisted they would keep me updated. Months later I’m looking at the component marketplace and see there’s two version of stripe kit. One of which is marked legacy.

I’m sympathetic to the growing pains adalo may be experiencing but, I feel as if this whole stripe component thing was not handled in good faith whatsoever.

Soo is anyone going to mention this to the countless users who’s apps that are currently running a depreciated legacy component?

*trying to keep my cool as a year and a half of work completely unravels

Hi Alex,

Is the new Stripe component working for you? I have an issue with the new Stripe component where it works in test but not in live?

I also don’t see a place to put the keys for live transactions which is weird? Did you just put them in the test mode key fields?

Very confused with this component.


Man, I will test this and let you know, but I appreciate this as one of the best efforts I have seen at responding to a question in this forum. So :clap::clap::clap:

I run a small agency I want to give you 2 hours of work from myself for any Adalo related work you may have. Anytime just reach out to me and let me know what you want done my friend.

1 Like

URGENT - Do not use the method I showed. Adalo API call information is publicly accessible, as are your stripe keys and custom action info. If you are using any custom action, you should run it through Zapier or, especially if dealing with payments.

I know this is a pain, but that’s the only way to do so with a tiny bit of security.

Hello everyone,
From my side, I do can pay (stripe considering PSD2 payment service), but after coming back to the app (I had to confirm the payment in the bank app), the submit button is loading, but never ends (not updating the user info, nor sending me to the Thank you page.
Anyone has bump into this problem?